0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
NAMM Show Report

SweetCare®

I upgraded to Pro Tools 7.4 on my Windows PC and now I am having problems with (various) plug-ins. Why?

In a few instances this was due to the customer upgrading his Windows to service pack 3. Since Pro Tools 7.4 requires a security update, those who choose to let their computer automatically update may inadvertantly updated their OS ahead of some of their plug-ins. Also, some third-party plug-ins may not be compatible with Sp3.

The solution would be to either update the plug-in in question or uninstall Sp3.

Refer to Sweetcare article # 32319 on how to uninstall SP3 or get the missing update for Windows SP2.