0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Microphone Month

SweetCare®

I can’t seem to get the Fostex RD-8 to work correctly with the ADAT I/O.

The RD-8 requires firmware version 2.02 or greater in order to function correctly with the ADAT Interface. Pro Tools 3.1 or higher is required as well.

Click here for 28,000 answers to your tech questions

Hundreds of Deals in the DealZone