rrrabuyvsvsveytfazersurdwarubawvev
0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Dad Gift Card

SweetCare®

UPDATED 11/13/2013: Information regarding Mac OS X 10.9 Mavericks and Avid Software

Per Avid, there are known issues with Media Composer 7 and earlier and Sibelius 7 and earlier within Mac OS X 10.9 Mavericks. It is NOT recommended to use any of the previously mentioned Avid software with OS X 10.9 as they are not supported at this time.

11/13/13 – Pro Tools 11.0.3 is now available and adds support for Mavericks. This update is ONLY compatible with Mac OS X 10.9 (Mavericks) and 10.8.5 (Mountain Lion). The co-install of Pro Tools 11.0.3 and 10.3.x will not work on Mavericks. The uninstaller for Pro Tools 10.3.7 will not work on Mavericks, along with the Nitris DX, Mojo DX, Fast Track, or VENUE FWx32 driver uninstallers.

Avid will announce support for the latest Mac operating system with future releases of Media Composer and Sibelius. Until then, we recommend waiting to upgrade your operating system if you are a regular user of Avid software.

For more information, click here.

Click here for 28,000 answers to your tech questions

Hundreds of Deals in the DealZone