0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Dad Gift Card

SweetCare®

Why doesn’t the Tascam DM24 recognize the new IFFWDM Firewire option card I just installed?

The DM24 needs to have the latest OS in it, version 3.0 or higher, for the firewire option card to work. This must be updated via MIDI from an external source, so a separate MIDI interface is needed to perform the update.

Click here for 28,000 answers to your tech questions