0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
February Giveaway

SweetCare®

The IFFWDMmkII card isn’t working in my Tascam Digital Mixer.

Because the IFFWDMmkII card is new to the Tascam line, most existing mixers will require a software update to work with the new card.

Required mixer versions are:
DM3200 v1.30 or later, supplied on Included CD ROM (only works in Slot1)
DM4800 v1.10 or later, supplied on Included CD ROM (only works in slot 1 or 3)

This can be verified by going to Alt+Utility and then to the System page on either mixer.

To update the mixer, use the TMCompanion software and the updates from the CD ROM included with the card.

Popular Related Products