0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Spring Clearance

SweetCare®

Cubase 5.5 does not load EuCon device with EuControl v2.5.5

Cubase 5.5 makes use of a brand new EuCon adapter from Steinberg, however it is installed as part of the EuControl installer (v2.5.5).

It is important to note that our installer intelligently looks for the currently installed version of Cubase and then installs the correct version of the EuCon adapter at that time.

This means you must install (or re-install) EuControl v2.5.5 AFTER you upgrade to Cubase 5.5. If you install EuControl v2.5.5 prior to installing Cubase 5.5 then the installer will place the previous adapter in the Cubase directory and it will not work when you upgrade to Cubase 5.5.

Popular Related Products