0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart

SoundToys & Lion

Version 4.1.1 of SoundToys software is not compatible with Lion and Logic, due to a minor issue with AudioUnits validation. The company is working on a fix and should have it soon.

For complete Lion compatibility info, visit our Lion Compatibility page, which we’re updating as new information becomes available.

Share this Article