0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Microphone Month

SweetCare®

What version of ProTools is required to use the UAD-1 card with the FXpansion VST to RTAS Adapter?

The Adapter allows Pro Tools Mbox, 002 and 002 users to use the UAD-1 plugins in Pro Tools v6.x

Click here for 28,000 answers to your tech questions