0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Microphone Month

SweetCare®

Is MachFive compatible with Logic in Tiger (OS10.4)?

Under OS 10.4 (Tiger), the AU version of MachFive 1.22 public beta appears to be compatible with Live, Garage Band and other AU hosts, and we are proceeding with ongoing AU testing. However, the MachFive 1.22 public beta is not compatible with Logic 7.01 under Tiger. Logic users must upgrade to Logic 7.1 to successfully run MachFive 1.22 under Tiger.

Click here for 28,000 answers to your tech questions