0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Microphone Month

SweetCare®

Apogee product compatibility and Mac OSX 10.5 “Leopard.”

To ensure your Apogee product works well with Mac OS X Leopard v10.5, it is critical that you follow the instructions provided at the link below.

If you have an existing Apogee software CD or a previously downloaded installer, please do not use it with Leopard. Only use the software and driver versions provided at the link below that are specifically indicated as “Compatible with Leopard.”

http://www.apogeedigital.com/leopard/

Click here for 28,000 answers to your tech questions