0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Microphone Month

Pro Tools 10.2 System Requirements

Version 10.2 of Avid’s Pro Tools 10 and Pro Tools 10 HD is qualified for:

  • Pro Tools systems on Mac OS X 10.6.7 to 10.7.3 or Windows 7 SP1
  • Pro Tools|HDX systems on Mac OS X 10.7 to 10.7.3 or Windows 7 SP1
  • Pro Tools|HD Native systems on Mac OS X 10.6.7 to 10.7.3 or Windows 7 SP1
  • Pro Tools|HD systems on Mac OS X 10.6.7 to 10.7.3 or Windows 7 SP1

Qualification for Mac OS X 10.7.4 is still in progress, so that OS is not yet officially supported at this time.

Avid Best Sellers

Share this Article