rrrabuyvsvsveytfazersurdwarubawvev0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
June 2017 Giveaway

iLok and PT9

Q: Does Pro Tools 9 require an iLok if I’m not running Avid hardware? If so, does it have to be the newer-style iLok, or does the regular iLok work?

A: All versions of Pro Tools 9 (including HD) require an iLok authorization in order to operate. If you buy a boxed version of Pro Tools 9, it will come with the new iLok 2. However, any iLok will work, so you can use an existing iLok you might already own.

Share this Article