0% Interest for 36 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
#WinYourWestones

SweetCare®

My UAD2 Satellite is not working with my 002 or 003.

Version 5.8 and below of the Satellite software is not compatible with the Avid 002 and 003. Version 5.9 will address these incompatibility issues. Version 5.9 is scheduled to be released in April of 2011.