0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
January Clearance 2017

SweetCare®

How do I configure the Tascam US2400 with Steinberg Cubase SX or SL 2.0?

First, you’ll need to make sure you have the latest version of Cubase SX or SL. As of April 2005, this is version 2.20, and is the first version that has large control surface support.

Then, make sure you have the latest version of the US-2400 drivers downloaded from the Tascam website . Version 1.20 and above contain Cubase 2.0 support. Then, follow the version 1.20 readme .pdf file for instructions on installing and configuring.