0% Interest for 48 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
Live Sound Month!

SweetCare®

Ableton Live crashes when I try to open a Live Set containing my Waves Plug-ins.

Ableton Live versions prior to Live 3.0.2 do not support Waves Plug-ins. You must have Waveshell 4.0.1 or higher and Live 3.0.2 or higher to use Waves Plug-ins with Live.

Check the Waves website for compatibility information to make sure that your version of the Waves plug-ins are the correct match for your version of Ableton Live.