0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart

Sweetwater Forums [Archived]

After 15 years of great discussions, the Sweetwater Forums are now closed and preserved as a "read-only" resource. For discussions about current gear, check us out on Facebook, YouTube, inSync, and our Knowledge Base.

Loud hum/buzz coming from Behringer XENYX 2442FX

djharoldrenny

Hello Everyone,
Need your help on this. I am running my Behringer XENYX 2442FX outputs to my PC desktop's sound card Line in. Very simple hookup (stereo 1/8 from the computer to RCA(mixer).
Result: music sounds great, however there is a strong hum/buzz present. I disconnected everything from the mixer, even turned it off. Low and behold, the hum/buzz is still there, blasting away.
I did another test by connecting my iPhone (via stereo headphone output) to the same sound card's line in. The result: Music played great (turned off the music), and ABSOLUTELY no buzz whatsover, even when the volume is raised.
I am stumped to figure out what is going on. Why is the Mixer bringing on this hum/buzz? Why is the iphone audio out so quiet? Is it a grounding thing? A loop or current issue?
Please help. Thanks in advance.
Max
indamixdjs@yahoo.com
February 26, 2013 @10:04am
Ted

Sounds like a grounding problem. Have you tried plugging the mixer into the same outlet that the computer is plugged into? If that doesn't do it you may also want to disconnect anything else that's connected to the computer that's not connected to the same outlet while you're recording.
February 26, 2013 @04:42pm