0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Microphone Month 3

Sweetwater Forums [Archived]

After 15 years of great discussions, the Sweetwater Forums are now closed and preserved as a "read-only" resource. For discussions about current gear, check us out on Facebook, YouTube, inSync, and our Knowledge Base.

PLEASE HELP - Firewire just won't work :-(


I am desperate. It has taken two weeks of hell and stress to give up and post on this website as a last resort!
I have a Dell XPS 420 with onboard Firewire (Texas Instruments chipset).
I purchased a Focusrite Saffire 56. It worked perfectly for one day, then the PC (which is vista 32) forgot about it and it stopped working. No firewire connection at all.
So I got an actual firewire card and plugged that in....nothing. I updated drivers/sp etc..still nothing. So I thought this must be an issue with the Focusrite, took it back and as they didn't have another one, got a TC electronic Studio Konnekt 48. Got it home, nothing.
Reinstalled Vista from scratch with full format, again updated all drivers/firmware. Purchased another firewire card. It worked for upto 5 minutes before it turned off my graphics card and the screen just goes onto standby and you have to power down. Did this for about 5 times before once again, no firewire at all.
Purchased Windows XP Pro and installed a dual boot system.....Nothing. Purchased a third firewire card (Allegro FW400). Nothing. NOTHING NOTHING NOTHING.
Contacted Dell and told them everything I had done and they said "Wow, well you've done everything we would suggest. I don't know. We'll get back to you next week".
So PLEASE anyone out there tell me - WHAT IS GOING ON???!!!!!!! My power is 375W which should be enough, the only other PCI device I even have is a graphics card and whatever I try just isn't working and I do not have a clue why or what I might need to replace.
Sorry for the large post but I couldn't have said it any shorter.
June 19, 2009 @09:35pm

Are all the firewire cards burnt out?
If so it's probably voltage problem with the motherboard.
June 25, 2009 @03:32am

I had a similiar problem with Windows Vista 64-bit and my MOTU 828mkii. The motherboard's onboard firewire didn't stop working but it kept causing windows to crash with a BSOD when the MOTU was connected. What I did was to uninstall all the Intel chipset drivers for my motherboard manually from the Device Manager and reinstall with the latest version, it has worked fine ever since. You can try that.
I noticed that mentioned you are only using a 375W power supply. What CPU and graphics card are you using? These two are the power hungry components in a computer.
July 10, 2009 @08:26pm