0% Interest for 24 Months! Learn more »
(800) 222-4700
  • Español: (800) 222-4701
Cart
#WinYourWestones

Sweetwater Forums [Archived]

After 15 years of great discussions, the Sweetwater Forums are now closed and preserved as a "read-only" resource. For discussions about current gear, check us out on Facebook, YouTube, inSync, and our Knowledge Base.

MBox2 Compatibility Issues

Fitzroy

Greetings folks,
So I'm the proud new owner of a MBOX 2. I recently completed my first album using a home setup with adobe audition, cubase, reason, and a m audio usb premobile, but I figured it was time to get into this pro tools thing.
My question:
MBOX2 is running fine with Pro Tools, but I can't get other software (soundforge, adobe audition) to recognize it. That's a problem for me, for while I am looking to become a pro tools junkie, I still want to manipulate older sessions i have in those programs.
Was I mistaken in assuming that MBOX2 worked with these other programs? I'm quite sure that I wasn't, as I'm certain that early in the game, just after installing the MBOX2, adobe was acknowledging its presence. Missing driver maybe?
Any assistance/insight would be greatly appreciated.
February 13, 2006 @07:42pm
John993

I too would love an answer to this same question as it will help me determine whether or not to get an Mbox2 or an M-Audio one for my laptop.
Fitzroy, a curious question did the Mbox2 work with Audition before you installed the protools software and if so have you tried uninstalling protools? I have a hunchy feeling that it's the protools software "blocking" the access to the Mbox2 from other programs. What does it say in Audition?
February 14, 2006 @02:17pm
Fitzroy

Yeah, I've tried uninstalling pro tools a few times, but it's been no help. Actually, I'm pretty sure that you have to complete the installation of the pro tools software in order for the mbox to even run. I'm at the point where I'm ready to reinstall windows and everything just to get back to whatever configuration i was at before.
February 14, 2006 @06:28pm
JGMX19

I’m not a 100% sure, but from my understanding all digidesign products are only compatible with pro tools. Hope this helps…
lata
February 16, 2006 @05:06am
Foreverain4

what exactly doesnt work? i can use my mbox 2 with vegas and acid no problems. be sure that you have the mbox asio driver selected as your default audio device within each program...
March 1, 2006 @02:03pm
Foreverain4

I’m not a 100% sure, but from my understanding all digidesign products are only compatible with pro tools. Hope this helps…
lata

it is actually the other way around. protools only runs on digidesign hardware. you can use their hardware with other software.
March 1, 2006 @02:07pm
CaptainAmerica

it is actually the other way around. protools only runs on digidesign hardware. you can use their hardware with other software.
I just recieved my M-Box2 yesterday. It was my intention to run this on a MacBook Pro (Intel). Being a new Mac user, I didn't know this wouldn't work so I installed anyway. The Mac didn't recognize the device. That's when I discovered the ProTool wasn't going to be avail for the Mac until Jun06. I happen to have an XP Laptop for work so I installed ProTools. It appeared to install fine but and all the lights go on in the device when I reboot. However, ProTools wont load. The "loading bar" gets to about 25% and hangs the entire system. Any ideas?
2) Question: I'd really like to use this with GarageBand since I'm a newbie to Audio. Also, a friend of mine uses Sony Acid, which I'd like to experiement with too, But if I cant get ProTools to work, am I stuck? Thanks from a newbie.
March 25, 2006 @03:17pm
zamboknee

Fritzroy,
I was wondering if you figured out how to connect your mbox 2 to your Audition?
I am encountering the same problem.
Audition 2.0 works fine with the Digidesign ASIO driver but trying to hook up Audition 1.5 to the mbox 2 is proving to be a pain.
Let me know please. Or anyone else for that matter.
Thanks,
zamboknee
December 29, 2006 @07:20pm
Kevyn


Hi there, I'm new here and I just wanted to share my recent experience with you all about this topic.
I also had a lot of different audio programs prior to getting my MBox2.
Acid Pro 5
Sound Forge 8
Sonar 6 PE
FL Studio 5 & 6
Reason 3.0.4
Live 6
ReCycle 2.1
Of all these, I have yet to get my MBox2 to work with Sonar or ReCycle. I can take files created with ReCycle and use them in Reason for use with PT but the software itself from my experience doesn't work and it just plan doesn't work with Sonar at all but that's to be expected since its a DAW just like PT.
It will be a headache to re-record all my previous projects from Sonar to PT but I don't really mind as I personally feel that my projects sound better on PT than it does on other DAW systems. Although I do keep Sonar and Acid handy for when I need to work with someone who has a preference over PT that way I can be as flexible as possible with my projects.
March 22, 2007 @02:48pm
sincere83

Greetings folks,
So I'm the proud new owner of a MBOX 2. I recently completed my first album using a home setup with adobe audition, cubase, reason, and a m audio usb premobile, but I figured it was time to get into this pro tools thing.
My question:
MBOX2 is running fine with Pro Tools, but I can't get other software (soundforge, adobe audition) to recognize it. That's a problem for me, for while I am looking to become a pro tools junkie, I still want to manipulate older sessions i have in those programs.
Was I mistaken in assuming that MBOX2 worked with these other programs? I'm quite sure that I wasn't, as I'm certain that early in the game, just after installing the MBOX2, adobe was acknowledging its presence. Missing driver maybe?
Any assistance/insight would be greatly appreciated.

depending on what version of audition you have.1.5 is a no no.2.0 is the one i've got my MBOX2 to work with.sound forge is one of my problems too.also sonar cakewalk 6 producer edition.thats about all i can tell you about the MBOX.
July 27, 2007 @10:48am
tech1

The driver for the MBox2 (and all other Digidesign interfaces) are first and foremost designed to be used with Pro Tools. Using it with other applications is somewhat of an afterthought. That being said, the ASIO driver is stable, and should work with applications that support ASIO. You will have to manually select this, though, as it will not usually be made the default driver.
* In Sound Forge, you will need to go to Options > prefernces > Audio and select the Digi ASIO driver. I'm not sure where AA 2.0 has it.
* In Sonar, go to Options > Audio > Advanced, and make sure you are using the ASIO driver mode. Then go to the Advnaced tab and select the Digi drivers only.
* Audition 1.5 uses WDM drivers only, so no, the MBox2 will NOT work. You can try the MME Helper, but ot's not a guarantee.
* ReCycle should be the samem as Reason: Edit > preferences > Audio.
I know this thread is old, but hopefully this helps someone.
July 27, 2007 @01:23pm
EsotericTT@aol.com

This is the only post I could find close to the subject. Maybe, I should start a new thread. Anyway, I have had a similar exprience with my 96 I/O hardware and Auditon 2, then 3.
I went to Audition hardware setup and chose ASIO driver. The hardware actually played Audition, and allowed me to record. The problem was a 3 second delay between transport actuation and actual operation. It's not a big problem with record, but editing is impossible.
Interesting enought, with Audition 2, the problem was 6 seconds delay for play and 8 seconds delay for record. This is complicated by the fact that concurrent with getting Audition 3, I upgraded Pro Tools to 7.4.
I did the msconfig thing and removing all startups changed nothing. In Adobe you can open the Digidesign ASIO Driver Setup. I varied buffer from one end to the other. The first time, I canged it to 256 from 1024. That produced a delay of less than 1/2 second. Feeling I was on to something I went in the other direction, 4096. Low and behold it was back to a 3 second delay. I expected much more. So, I set it back to 256 and the previous benefit did not recurr. I don't understand what happened, but I saw light at the end of tunnel for only a brief time.
Also, don't waste your time on Audition forums. The users there hate Digidesign, and probably you, for purchasing it. All I got was snide remarks and castigation for attempting to use Pro Tools hardware. Out of 4 or 5 responses all but one was put-downs by people on ego trips, not suggestions.
January 18, 2008 @01:19am
MRB&4ZK

Hey Fitzroy
I have Pro Tools LE 7.4 installed and am using the M Box 2 as my interface on my audio pc. Sound Forge 9 works fine with the M Box 2. When you open Sound Forge go to Options then to Preferences. In the list for audio device type, choose ASIO Digidesign driver and the M Box will appear in the routing list below. Now you are set to use it. I LOVE the sound of the M Box.
MRB&4ZK
January 13, 2009 @01:17am